Adobe Acrobat

From NoskeWiki
Jump to: navigation, search

About

NOTE: This page is a daughter page of: Adobe


Adobe Acrobat is a family of computer programs designed to view, create and modify Adobe's Portable Document (PDF) files. Adobe Reader (formerly called "Acrobat Reader") is a program installed on most computers to allow viewing of these popular PDF files, but to actually create PDFs requires you to fork out a fair amount of money for a "Adobe Acrobat Standard" or "Pro" version. As of version 9, the four different members of the Acrobat family are:

  • Adobe Reader - allows you to view PDF files and is free (download the latest version here)
  • Adobe Acrobat Standard - (~$300) allows you to create PDF documents from other files including image files and most office products
  • Adobe Acrobat Pro - (~$500) as above + a few more advanced editing and signing features
  • Adobe Acrobat Pro Extended - (~$700) as above + ability to capture and/or directly import 3D files and certain videos into your PDF documents.


The differences between these versions is outlined in more detail here.


Inserting 3D Files into a PDF

Please note that to insert 3D content you'll require an "Extended" or "3D" version of Acrobat. The ability to embed 3D files was first introduced in 2005 with "Adobe 3D", but in these instructions I used "Adobe Acrobat 9 Pro Extended" which includes the features of Adobe Presenter and Acrobat 3D and it isn't available for Macs yet but you can download a free trial for Windows here.


Adobe Acrobat can directly import several popular 3D formats including: 3DS, 3DXML, DXF, MAX, DGN, IGES, 3DM, VRML, and OBJ. To see a list of supported formats click (Ctrl+N) or File > Create PDF > From File on the toolbar then click the "files of type" dropdown and you'll see: 3D Studio Mesh (*.3ds), 3DXML (*.3dxml), AutoDesk AutoCAD (*.dwg, ...), CARTIA (*.model,...), SolidWorks (*.sldasm,...),Universal 3D (*.u3d), VRML (*.vrml, *.wrl), Wavefront Object (*.obj) and several other 3D file formats.


The easiest method to create a PDF with 3D content is to "drag and drop":

  1. Open Adobe Acrobat 9 Pro Extended
  2. Drag your 3D file from your desktop onto this window to import it
  3. Enter the desired import settings you want, then save the file as a PDF


If you program file format isn't supported an more versatile method is to use the "3D Capture" feature, which automatically finds other applications running OpenGL and captures this content. Once your other program is running simply go: File > Create PDF > From 3D Capture in Acrobat then follow the instructions, which will involve identifying the program running 3D and then pressing the PrintScreen key while that program is active. An excellent video demonstrating how this was done to capture a molecular model from "Pymol" here. Using this same process I've also been able to capture data from the program 3Dmod Model View, although the easier/faster method is to convert it to a .vrml first by running "imod2vrml input.mod output.vrml". Ideally you may want to first use a program like Cinema 4D to clean up the model, add text and lighting and then import it into Acrobat Pro Extended.


One the model has loaded, you click the "Toggle Model Tree" icon to see all the elements and you can click to show and hide each element. There are also many options to change the lighting and drawing modes, and to save any view click the "Create View" icon under the Model Tree. When the PDF is viewed the user can quickly switch between all these views, and in each one you can highlight a different feature of your model.

By default, the imported 3D model takes up a whole landscape A4 page, however to modify the size of this you can click Tools > Multimedia > 3D Tool. While this is open you can resize the area of the 3D image.


Links