Adobe Illustrator

From NoskeWiki
Jump to: navigation, search

About

NOTE: This page is a daughter page of: Adobe


Adobe Illustrator is a surprisingly powerful vector-based drawing program.

I used Illustrator to make all my scientific figures, which I typically export at high resolution (600 or 1200 dpi) as .PNG or .TIF files. I also use and recommend Illustrator to create posters (see: IMB - making a poster)... for me its two major strengths are that: (1) it allows precise positioning and alignment of text / images and lines and (2) it lets you import images as "links" thereby reducing the file size of your .AI file and allowing *relatively quick loading and display.


My Preferences

Before I start drawing I draw I like to set the minor grid-lines to a millimeter by going: Edit > Preferences, then setting one centimeter with 10 divisions. To show the grid go: View > Show Grid and turn on snapping go View > Snap to Grid or press [Ctrl]+[Shift]+["].


Converting a Bitmap to a Vector

  • Paste your bitmap into Illustrator.
  • Select the bitmap with the normal select tool (the black arrow).
  • In the top bar, click the "Image Trace" or "Live Trac" option... or select the drop down for "Line Art".
  • Copy and paste into another program if desired!

See all steps illustrated here: Turning a pixel image into a vector image using Adobe Illustrator CS5


Creating a Scientific Figure

Most journals provide regulations about image size, type and resolution, which I've written about in Scientific Journal Guidelines, but as a rule of thumb: make the figure 12 cm wide, use only Arial with font size >= 6 and export as a 600 dpi .TIF .

To create a figure for a science publication:

  • Create a new folder called "fig X - size graph" (within your "figures" folder), and under that create a folder "imports".
  • Copy or move all the image files (including .PDFs) you want to use in the figure in the "imports" folder.
  • Open Adobe Illustrator.
  • Start a new document, setting size to "Letter" (size of most journals in the US), units as "centimeters" and color mode as "RGB" (unless journal insists on CMYK).
  • Turn on the grid with View > Show Grid.
  • Import your image(s) by going: File > Place and Make sure "Link" is ticked.
  • Re-size images to the correct width by dragging and holding [Shift] or using the Width box.
  • Move image to approximate center of page.
  • Add any text /lines etc to the image.
  • Save the file as an adobe illustrator file (eg: "fig_profile.ai")
  • Export the image by going: File > Export, then choose .tif, then select 600 dpi CMYK.
  • NOTE: If you check the image and it's not cropped correctly, go: Object > Crop Area > Make, and then: Object > Crop Area > Release. Drag the edges of the crop area to the appropriate size.


Importing Graphs from MS Excel

The easiest method to import a graph from Excel is simply to select it and copy [Ctrl+C], then switch to Illustrator and paste [Ctrl+V]. You can now right-click and "Ungroup" this to move around text and lines. I have found however, this copy-and-paste option sometimes affects my formatting, so often I will make the Excel graph "as new sheet" and using the Adobe PDF > Convert to PDF feature (available in Excel if you've installed Adobe Professional) I export this page as a PDF, and then File > Place this into my document.

Importing Vector Graphics from MS Word

I find MS Word (and sometimes MS Excel) easy to quickly make drafts for figures, since you cut and paste and add arrows connectors easily. Although you can use Adobe Professional to export MS Word and MS Excel files as high resolution PDFs (and then crop them), MS Word lacks the precise control and layer system of Adobe Illustrator. Usually you can select lines in Word, copy and paste into a layer in Illustrator. I also discovered by accident that if you import the word document into Illustrator, then delete it, and THEN import a PDF of the same file you can often ungroup all the lines. Often however, it's just as quick to import an screenshot or just the PDF into a "bg" layer, dim the layer to 20% and lock it, then trace it using the line and pen tool.


Special Shapes

Under the line roll-out there are a few objects, like grids, which are pretty cool - if you click once, you can specify how many dividers etc. However, unlike MS programs Illustrator doesn't feature autoshapes (shapes with draggable controls).

Arrow Heads

To create an arrowhead, draw and select a line, then click: Filters > Stylize > Add Arrowheads... and select desired arrow-head and size. For subsequent lines go: Filter > Add Arrowhead or press [Ctrl+E].

Dotted Lines

When drawing lines and paths you can change the way edges and endpoints are chamfered. To create a dotted line I create a line of thickness 1, then create a dashed line with 0 on and 2 off, then tick circular chamfer, and if you shorten the line down to nothing it appears as a single dot/point.


Links