IMOD - preparing images for publication

From NoskeWiki
Jump to: navigation, search

About

NOTE: This page is a daughter page of: IMOD


This page represents a concise guide to preparing images for publication in the program IMOD, with special thanks to my old PhD supervisor Brad Marsh.



Preparing an image for publication from IMOD

Step 1: Saving the image in IMOD

  • Check that object colors (for various organelles) match RGB values from previous publications/datasets (see IMOD - naming objects for more info).


  • If using ZAP window:
    • Make the ZAP window as large as possible and zoom to the desired area.
    • You may want to toggle to high-res image (the button with the checkered pattern).
    • Make a note of the slice number and the black and white levels.
    • Press [Ctrl]+[t] to remove little yellow crosshair.
    • Go: File > Movie/Montage
      • Select Snapshot as "TIFF"
      • Turn on "ZAP montage" and use the value "4" (this ensures a HUGE tiff IMAGE).
        • NOTE: ZAP montage many only work with IMOD version 4 and higher.
      • Take a single TIFF snapshot by using [Ctrl]+[S] or [Apple]+[S] (if on a Mac)
      • The image zap000.tif will be saved to your IMOD home directory.
      • EXTRA TIPS:
        • When the montage is made you'll see the ZAP window zoom in and jitter around, but it doesn't scale up the actual lines, meaning that the contours in "zap000.tif" will appear very thin in the final image. To make the lines thicker the only solution I know is to go to Edit > Object > Type and scale up the line with, the repeat this for every object.
        • Most tomograms are too big to fit on your screen at 1x zoom, so click [-] till it all fits then press [Ctrl]+[R] to shrink the window to fit the image perfectly. If you want your final image set such that that each pixel represents one tomogram pixel you can do this by making sure that: ZAP zoom x the montage number = 1. So for example, if you find have a zoom of 0.25 (displayed on the ZAP bar) you would then set the montage value to 4... and the output will be original size.


  • If using MODEL window:
    • Press [g] FOUR times to maximise gouraud shading (makes spheres look smooth).
    • Set up view how you want it, minimize white space.
    • Save the view by going: Edit > Views, then click "New View" and "Store" (allowing you to come back and use this view again later)
    • Go: File > Movie
      • Set Make to "Montage" and Write to "TIFFs".
      • Set the # of montage frames as "4" and turn on "Write files".
      • Click "Make"
      • The image modv0000.tif will be saved to your IMOD home directory.


Step 2: Photoshop

  • Open the image file using Adobe Photoshop.
  • Use the crop tool to get rid of ALL white space.
  • Go: Image > Image Size
    • Make sure resample is NOT selected.
    • Change the resolution to 400 pixels/inch.... (or as specified by desired journal)... and click okay.
    • NOTE: Hopefully the document size width is > that specified for the journal.
  • Save the file in a new folder. (eg: "Paper/Figures/Figure 1/cell_profile.tif")


Step 3: Illustrator

  • Open Adobe Illustrator.
  • Start a new document, setting size to "Letter" (size of most journals in the US), units as "centimetres" and color mode as "RGB" (unless journal insists on CMYK).
  • Import the image(s) by going: File > Place. Make sure "Link" is ticked.
  • Resize it to the correct width by dragging and holding the Shift or using the Width box.
    • NOTE: For most journals, a 1 column image is ~9cm, 1.5 column ~12cm & 2 column ~18cm.
  • Move image to approximate center of page.
  • Add any text needed on the image.
    • NOTE: Most journals want text size to be >= 6 points and <= 10 points. Brad uses Helvetia, but Arial should also be okay.
  • If this figure consists of several panels, make sure the combined width is correct, and label them as A, B, C (unless specified otherwise).
  • Save the file as an adobe illustrator file. (eg: "cell_profile.ai")
  • If the journal site wants the figure attachments to be cropped go: Object > Crop Area > Make, and then: Object > Crop Area > Release. Drag the edges of the crop area to the appropriate size ready to export the image.
    • NOTE: The exported image will use the cropped area.
  • To export the image go: File > Export...
    • Select either TIF (and save with appropriate DPI) or JPEG (at maximum quality). (eg: "figure_1.tif")


See Also


Links