QuickTime

From NoskeWiki
Jump to: navigation, search

About QuickTime

QuickTime player is a free movie player for Mac and Windows. Quicktime comes pre-installed on Mac computers, or can be download free from the Apple site.

What not everyone knows however, is that, for a small fee, you can unlock QuickTime 7 to enable the "QuickTime 7 Pro" features - and this is actually a great little program for compressing movies and making simple edits. On this page I talk about using QuickTime 7 Pro to edit and compress movies.


Unlocking QuickTime 7 To Edit Movies

If you want to edit movies, you will need to download QuickTime player version 7 from here. Editing is not well supported in the later versions, so make sure it is version 7! Once installed, you will need to unlock the QuickTime 7 Pro by clicking menubar > Help > Buy QuickTime Pro.... A license for Quicktime Pro is only $30, which is pretty reasonable. Once you have registered and entered a serial number, the "Pro" movie editing features which were formally locked are now unlocked and ready to use.

NOTE: QuickTime X can also be unlocked for editing, but only on Mac and only if you have Snow Leopard (or later OS X) installed. I haven't had much luck with it myself - I prefer version 7.


Making and Editing Movies in QuickTime 7 Pro

Making a Movie from an Image Sequence

If you have a sequence of (same sized) images in a numbered sequence (eg: zap000.tif, zap002.tif, ... zap099.tif) you can go: File > Open Image Sequence and select the first one. NOTE: With QuickTime Pro on a MAC you also specify the number of frames per second, while with Windows versions you'll have to change this later.

By default QuickTime will save as a uncompressed .mov file. This is the best format to save as because it keeps maximum quality... but on the downside it has a huge file size, so you'll probably also want to save a compressed version use the Export feature.


Exporting Movies

When you have a movie file open you can export it to one of many different movie formats by going: File > Export. The option I recommend is "Movie to QuickTime Movie" - especially if you use a MAC. If you click on Options you can change the desired Size and Settings of the movie. By default "Movie to QuickTimeMoive" should save your .mov file using "H.264 compression" - a compression I highly recommend as it gets really terrific compression with minimal quality loss. If you want to play around with compression you can also set the "kbits/sec" under "Options > Settings" - this value will dictate the size of the file and movie quality. The only other setting I use is AVI files ("Movie to .AVI"). I'm not a fan of .AVI compression, but the advantage of .AVI is it plays on pretty much every machine (sometimes H.264 won't work on Windows machines) and it's the only movie format you'll be able to play in MS PowerPoint on Windows. Sad but true.


Editing Movie Frames

To cut or copy frames you must use the selection markers at the bottom of the timeline to make a selection... and then use the cut and copy commands (under Edit). You can then paste at the position of the play head. If no selection is made a single frame is cut.

If you have multiple movies open you can copy frames from one to the other. You can use this to append one movie on the end of the other.


Combining Two Similar Movies

Often people will want concatenate/join movies by putting two movies side-by side in a single movie (especially in science). Ideally both movies will have the same dimensions and number of frames. To put them side by side:

  • Select ALL the frames in the second movie, and copy [ctrl+c].
  • Select the first movie, put the play head to the beginning, and go: Edit > Add to Movie. (this is the part I forget)
  • In the first movie go: Window > Show Movie Properties, where you will notice two video tracks.
  • Select the second video track and click the "Visual Settings" tab.
  • Under "Offset" enter the width of the first movie in the first text box. You should now see the movies side by side.
  • Close the "Properties" window and check the movie is as you want.
  • Save the movie as "combied.mov" or something similar.


Adding a Watermark

To add a watermark to QuickTime works best if you use a transparent PNG (see here):

  • Use Adobe Photoshop, Adobe Fireworks or any other good graphics program to make a new image the same dimensions (width, height) as your movie and a transparent background.
  • Create your watermark down the bottom and then save/export this as a PNG with alpha transparency.
  • Open the PNG in Preview, select all with [ctrl+a] and then copy using [ctrl+c].
  • Open your movie (.mov) in Quicktime.
  • Select all frames [ctrl+a] or a subset of frames you want the watermark to appear.
  • Click Edit > Add to Selection and Scale and your image will appear over the top, but without transparency at this stage.
  • Click Window > Movie Properties to edit the movie's properties.
  • Select the watermark track (it should be called "Video Track 2"), then under the "Visual Settings" tab set the transparency to "Straight Alpha".
    • NOTE: Even though your image is the same scale, there's a chance you'll have to play with the scaled size and offset values to get it looking right
  • Preview and then save and/or export your movie.


Taking Full Scale Screenshot at a Particular Frame

  • Open your movie in Quicktime 7 Pro.
  • Drag slider and use left/right keys to find exact frame (do not select a range).
  • Make sure video is full size [ctrl+1].
  • Go Edit > Copy or press [ctrl+c].
  • Open a program like Paint or Adobe Photoshop and paste with [ctrl+v].


Exporting to Popular Media

Exporting to iPad

Ipad is a very hot topic. Quicktime 7 has a export preset for iPhone, but not iPad, so you will have to go "File > Export", "Movie to Quicktime Movie" then under options make sure you have H.264 selected, make sure your movie isn't over 30 frames per second and (MOST IMPORTANT) change the size to "1280x720 HD".... and you'll probably also need to tick "Preserve aspect ration using: Letterbox" (since your aspect ratio is probably different). If your movie has sound, "MPEG 4" with up to 160 Kbps is supposed to work. There are few other codecs for video (including MPEG 4) and audio that may work (see here), but the size is most important thing to get right.


Exporting to YouTube in HD

YouTube will accept many formats, but I've had problems with the sound going missing or out-of-sync depending what codecs I use. Following instructions for this video, they suggest: "File > Export", "Movie to Quicktime Movie" then under Options > Video make sure you have H.264 selected and recommend ~10,000 kbits/sec (or leave blank) and "Faster endode (Single pass)". You should also change the size to "1280x720 HD" (same as iPad export) and will probably need to tick "Preserve aspect ration using: Letterbox" (since your aspect ratio is probably different). Under "Sound" select "AAC", "Mono", "44.1 kHz", "Better" and "96 kpbs". You can also uncheck "Prepare for Internet Streaming". Using these settings you should have good quality of video and sound.


Links

TIP: If don't have QuickTime Pro ImageJ can also be used to make movies.