Adobe Photoshop

From NoskeWiki
Jump to: navigation, search

About

NOTE: This page is a daughter page of: Adobe


Adobe Photoshop is Adobe's flagship product and the primary market leader in bitmap image manipulation and professional graphics design. Photoshop's native format is .PSD and it supports RGB, lab, CMYK and grayscale. As of CS3 Photoshop broadly supports using layers to create animations and even making menus for DVDs.

In the past I've opted to use smaller applications for basic image modification (resize, crop etc), however with faster computers nowadays Photoshop doesn't take as long to load, and you can leave it open and drag files in for batch processing when needed.


You can see a video of the latest features here.

Photoshop has way too many features and intricacies in to mention, but below are a couple of references for myself.


Child Pages

Related/Child Pages:


Converting Pictures into a Movie (Using Photoshop)

  1. Go: File > Scripts > Load Files into Stacks... (This option will add all your image in as one file with separate layers) and add all the images you want in the animation.
  2. Open the Animation Palette under: Window > Animation.
  3. Click on the Flyout Menu on top right corner of the animation window and select Make Frames from Layers.
    NOTE: If your frames are backwards click the bottom left icon to of the animation window get into "frame animation mode", select all the square frames then click the flyout again and "reverse frames".
  4. Adjust the timing of each frame by selecting the 0 sec. on the frame.
  5. Go: File > Export > Render Video. Among the many options you can save as a movie for Flv, IPhone, IPod, Quick Time, MPEG4 and so on. I recommend using compression type "H.264".


Turn a .MOV or Other Movie File to an Animated GIF (Using Photoshop)

  • Go: File > Import > Video Frames to Layers... and select your .mov file. Consider skipping every 2 frames if higher frame rate than needed, and trim to a few seconds.
  • Go: File > Save for Web... then select "GIF".

... also consider trying Adobe Media Encoder


Batch Processing Images Using JavaScript

A particularly powerful part of Photoshop is not only the option to record a sequence of actions and repeat/automate this for multiple images. Taking batch processing a set further, you can also write your own Adobe JavaScript File (.JSX), and in the past I've used this to recreate montages, and at one stage wrote a Visual Studio C++ app to provide a small GUI to help align images.

I've written a few .jsx files here:

A full CS5 .PDF scripting reference is here.


Making a 3D Anaglyph

Anaglyph images are stereoscopic images which look 3D when viewed with colored (typically red and cyan) glasses. To make such an image you first need two separate images of the same scene taken from slightly offset angles, the same way your eyes are offset. Using a 3D animation/rendering programs (eg: Blender, Cinema 4D, etc) you can generate these two images by slightly rotating and then offsetting the camera to produce two different angles (see: making 3D anaglyph images using Cinema 4D). In the real world you can get the same effect in the real word by taking two picture of the same scene from slightly offset positions. To get this good requires require a steady hand and post alignment of images in Photoshop. For a more expensive option you need two cameras mounted side-by-side and rigged to go off at the same time, thus allowing you to capture a scene contains moving object (eg: moving cars). Once you have your two stereo pair images you should name them "left_eye.tif" and "right_eye.tif" and can turn them into an anaglyph using the following instructions.

  • Open "left_eye.tif" in Photoshop.
  • Next we want to add "right_eye.tif" as the second layer in Photoshop. The slower approach to doing this is: open right_eye.tif in Photoshop, then select and copy the whole image by pressing [ctrl+a] then [ctrl+c]. Now close this image and with your left_eye open click [ctrl+v] to paste this as a new layer on top.
    • TIP: As a quicker alternative, most version of Photoshop should allow you to select right_eye.tif in your file explorer, then drag this file ONTO the left_eye image within Photoshop and hit [Enter].
  • In the "Layers" panel (toggle this with [F7]) you should now see two layers. Right click the top ("right_eye") layer and select "Blending Options".
  • In the "Layer Style" window under "Blending Options" and "Advanced" blending uncheck the "R" channel so that only the "G" and "B" are left on then click Ok.
  • Select the bottom layer and click the lock button to unlock it.
  • Right click the bottom layer, chose "Blending Options" and turn off the "G" and "B" channels so that only the "R" is left on (for the left eye).
  • Find an put on a red and cyan glasses. Red should be over the left eye and if you don't have glasses already some easy instructions are here.
Creating an anaglyph in Photoshop using two layers with "Blending Options" on the top one


You should now see the classic "anaglyph" image such as the one below. What we did is changed the top layer to only display the red channel, such that we can only see the green and blue (together making cyan) channels from the top layer, and only the red channel of the layer underneath. Before you save this image, you might first want to play around with the alignment. Our eyes never really points parallel to each other - they focus in on an object in the foreground, so to make this a little more realistic, we can move around the top layer:

  • Select the top layer and click the "Move tool [V]" in the toolbar.
  • Use the left and right arrow keys to adjust the top image until you see a minimum amount of red over the object you want most in focus. In our C4D example, try to minimize the blurriness around the front-most ball.
  • Use your 3D glasses and move your head from side to side to check the effect. Notice if you move the images too far apart it will be difficult for your eyes to stay in focus.
  • Finish by using the crop tool to crop the image to remove the bits on the left and right where only one layer appears.
  • Use File > Save As to save the image as "my_first_anaglyph.tif".
Final anaglyph in Photoshop after alignment


Links