YouTube - uploading 3D side by side videos

From NoskeWiki
Jump to: navigation, search
A 3D empowered video in YouTube uploaded and currently displayed as a side-by-side stereo pair (for a suitable projector and glasses)... you can watch the video here

About

NOTE: This page is a daughter page of: YouTube


YouTube added support for 3D videos as long ago as 2009. Since then, they've added functionality to switch between various formats (red-blue, interleaving and stereo-pair) and even a feature which will try and automatically convert 2D movies to 3D. All these methods require 3d glasses and/or special 3D displays - unless you want to use stereo-pair and attempt to go cross eyed. To upload a 3D movie, the best way is to upload a video with a side by side stereo-pair display - with the left eye on the left side and the right eye (slightly shifted in position/angle) on the right side - and YouTube should supports a final resolution up to 3840x1080 (two times 1920x1080) - although typically you'll want to squash your image in X.

Certain 3D cameras will produce side by side left and right 3D videos automatically, but here I've written instructions on how you can use a 3D animation program (in this case using Cinema 4D as an example) and QuickTime to generate L/R stereo-pair videos suitable for uploading to YouTube.


Step 1: Making a left and right videos in 3D software

Setting up a left_eye and right_eye camera in Cinema 4D

The following instructions work for Cinema 4D but the principles apply to almost all 3D programs. Chances are you already have a camera (preferably a "target camera") which is in your scene and possibly already animated. That's fine - think of this as representing the middle of your vision and rename it "Main Camera".

  • Create a new target camera with Object > Scene > Target Camera and then rename this camera "left_eye".
  • Rename the target which was just added (most likely called "Camera.Target.1") to "focus_point".
    • NOTE: You could also use a normal camera (without a target) but if your eyes stay parallel through the video then you have no real focus and it won't produce a good video.
  • Make your "left_eye" camera a child of your "Main Camera", the go to the properties and set everything (angle, scale and rotation) to zero, so that it's exactly in line with Main Camera.
  • Now alter the "x" position to be "-2.5 cm" (your eyes are about 5 centimeters apart, and lets assume for now your movie is at a good scale for human eyes).
  • Copy "left_eye" using shift drag or (ctrl+c, ctrl+v), then rename the new camera "right_eye" and flip its x position to "2.5 cm".
  • Toggle the little cross hair next to the left and right eye cameras to see a difference. Through the movie you'd like to see a small difference (less than a few degrees) in shift for all the objects in your scene. If you see a huge shift (> 1/4 the width) your eyes are probably too far apart and if you see no difference your eyes are or too close together, and you should refer to the guidelines below. Human space eyes are best for viewing things a few meters away, but if you have a really tiny or huge scale you'll probably want to shift your eyes appropriately so things "pop out" the right amount.
  • If you already have a camera target for you "Main Camera", then click each of your eyes, click the "target" tab and change them to use the same target as Main Camera. If your main camera doesn't have a target, right click it then select "Cinema 4D Tag > Target", and then make its target tab point to the same target as both eyes. Throughout your movie the target should move to wherever you want your eyes to focus. Just like with real vision, stuff really far behind or in front of this target will appear more "blurry".

GUIDELINES FOR SETTING A GOOD DISTANCE BETWEEN YOUR EYES:
As a rule of thumb you should place your eyes about 1/20th the distance to whatever you're looking at is quite comfortable. If you find this is too little (the images don't pop out far enough), it can help instead to position your eyes so they form about a 5 degree angle with whatever your looking at.

Our cameras now exist, but we now need to render them.

  • In the main menubar click: Render > Render Settings. In the render settings window select the "Output" tab and change the size preset to 1024x800 and change the "frame range" from "current frame" to all frames.
  • Select the "Save" tab, and then change the format to "QuickTime Movie". To make it save, type "left_eye.mov" as the "file" and close the render settings.
  • In the Objects window set the "left_eye" camera as the currently active camera by clicking the white target crosshair just to the right of it.
  • With the main viewport now set to the "left_eye", click the Render to Picture Viewer icon (or Render > Render to Picture Viewer) and it will render the animation as a quicktime movie saved as "left_eye.mov".
  • Change the currently active camera to "right_eye". Under Render > Render Settings, change the output to "right_eye.mov" close and then render again.
  • Now's a good time to save your c4d file too.
    • TIP: You can only render one movie at a time in Cinema 4D, but if you have a 64-bit machine you probably have both a 64 and 32 bit executable, and you can have one render the left at the same time the other renders the right.
    • Rendering a movie is VERY slow, so I suggest rendering just the first 60 or so frames the first time you try this to make sure you eyes behave correctly and are spaced a good distance apart before committing to rendering the whole movie.
    • Reminder: If your Main Camera has a target this is great, you can give you left_eye and right_eye the same target (right click it then "Cinema 4D Tag > Target") and it will have a better effect of your eyes "focussing" on that point during the movie. If there is no target you can experiment with VERY slightly angling the left_eye and right_eye towards each other, but that can be a bit tricky/dangerous depending on where you camera moves.


Step 2: Combining the movies side by side in QuickTime Pro

  • Open "right_eye.mov" in QuickTime Pro then click Edit > Select All [ctrl+a] then Edit > Copy [ctrl+c] in the menubar to select all frames and then copy them.
  • Close "right_eye.mov".
  • Open "left_eye.mov" (in QuickTime Pro) then click Edit > Select All [ctrl+a] then Edit > Add to Selection & Scale. Both movie will now be directly on top of each other.
  • Click Window > Open Movie Properties to open the Properties window. The left eye movie will be Video Track 1, and the right eye will be Video Track 2. Select Video Track 2 and click the Visual Setting tab. Now using the Offset, change the the first value to width of the video file (1024). In the Player window both video tracks should be side by side.
Combining two movies side by side in QuickTime Pro 7
  • Click File > Save as to save this both.mov.
    • If you have a special stereo pair enabled projector or screen now's a good time to make it full screen, put on your 3D glasses and see if it works.
    • You can try uploading this file to YouTube as is, but chances are it will be too big or look funny. According to the official instruction: "YouTube 3D works best with ... H264 AVC 1920x1080 Side by Side L/R with SEI Frame Packing Arrangement metadata" and so lets do that.
  • Click: File > Export, select "Movie to MPEG-4" and click "Options".
  • In the MPEG-4 Export Settings set the video format to H.264, set data rate to 10,000 kbps/sec (if you want to make a smaller video you can try reducing this later, but youtube can handle big videos) and Key frame to automatic. Most important, you will probably have to change the Image Size from Current to Custom, and half the size of the video in X - such that our example here would go from 2048x768 back to 1024x768. This reduces the quality in X, which sucks, but YouTube seems to expect this. If you don't do this I've found my videos become stretched in X... although you'll also notice a 3D option to switch between "half and full width" within the YouTube player's 3D options.


Step 4: Uploading your 3D movie to YouTube

Hopefully you already have a YouTube account, so will know how to upload videos. The trick to it is that when you upload a 3D video you'll need to go to the "Advanced Settings" tab (top right) and change the options under "3D video:" to read "This video is already 3D" and "Side by side: left video on the left side".


Step 5: Previewing in YouTube

Once uploaded you should be able to go to your feed and you'll noticed a "3D" icon appear at the bottom of your video. At this stage you should put on whatever 3D glasses you have. Although uploaded as a side-by-side YouTube can convert this format on the fly to interleaving or red-blue glasses. Make sure you switch to the appropriate output and play with the 3D settings. It's possible you'll have to switch your left and right or switch from the default half width to full width for the best effect.

As a warning: you'll probably be unhappy with the results the first few times, meaning you'll have to go back to your 3D file then repeat the entire process of rendering, combining, uploading and previewing. For this reason I (once again) highly recommend you try just a small subset of the video for expedited rendering until you're sure you have the eyes working correctly and have established the best size to render and export at. In my case I wanted to project on a 1024x768 (4:3 ratio) dual projector system, but you may want to project onto a wider screen and thus want a wider aspect like 1920x1080.


See Also



Links